Follow

The LED on my trainer is dead and the trainer doesn't work

The Problem

If the following symptoms are all present with your new Control or R1 trainer:

  1. LED light on trainer resistance unit is dead
  2. LED light on power strip is working
  3. There is no sound coming from the trainer when plugged in (electronic trainers home the stepper motor each time they are plugged in, you'll hear a short period of motor sound)
  4. The trainer may have never worked or may have worked briefly

 

The Diagnosis

You may have a bad fuse on the printed circuit board (PCB).

 

The Solution 

If you're experiencing this set of issues and suspect you have a bad PCB in your resistance unit, please do the following:

  1. Fill out a warranty claim HERE
  2. Include the trainer serial number and any purchase receipts or information you can provide
  3. Describe what is happening and note that you suspect a bad PCB

We will send you a PCB replacement kit with instructions for swapping the board. Performing this repair will NOT void your warranty on the trainer if we send you the kit. The kit contains a board, instructions and two torx wrenches for removing the trainer housing and replacing the board (below).

Control_R1_PCB_Kit.jpg

 

Important Note

This PCB-fuse issue is confined to a very small number of new Control trainers and R1 trainers. This issue is not associated with Smart Control trainers or inRide sensors. 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.