Follow

What Android devices are supported?

Kinetic Fit for Android requires the following:

  • Android 4.4 or higher (KitKat)
  • Bluetooth LE Hardware

We are working to support 4.3 (Jelly Bean) but there are numerous issues with Bluetooth LE support in Jelly Bean (4.3). During the Beta period, you will still be able to install the app on your 4.3 device and we welcome any feedback and bug reports, but be aware that we are not committing to full support for 4.3 (yet).
Development and Testing is being performed on:

  • Nexus 5x, Android 6.0
  • Nexus 7 (2013), Android 6.0
  • Samsung Galaxy S4 w/ Android 4.4.2
  • Samsung Tab S w/ Android 5.0.2

We will be adding more test devices over time. Expected device compatibility:

  • Samsung Galaxy S3 and newer
  • Motorola Moto G (2nd gen) and newer
  • Sony Xperia M2 and newer
  • HTC One M8 and newer
  • LG G3 and newer

Due to the sheer number of Android devices, it is literally impossible for us to test every device variant + OS combination. We will do our best to test on the "Lowest Common Denominator" devices and as many Android versions as possible.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request